<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="HandheldFriendly" content="true">
<meta name="google-site-verification" content="m7yGlHpWqFPUfI8QK06QXuo9A3kEnoiRZsOPFgoSNb4" />


<meta name="title" content="Author Janet Wong Brings a Poetry Suitcase to Briarcliff Manor" />
<meta name="description" content="Janet Wong, author of over 30 children’s books and volumes of poetry, visited Todd School in Briarcliff Manor this spring to talk to students about her love of language and the importance of poetry. Recalling that as a child she missed a chance to learn another language out of fear that others would make fun [&hellip;]" />
<meta property="og:description" content="Janet Wong, author of over 30 children’s books and volumes of poetry, visited Todd School in Briarcliff Manor this spring to talk to students about her love of language and the importance of poetry. Recalling that as a child she missed a chance to learn another language out of fear that others would make fun [&hellip;]" />
<meta property="og:url" content="https://riverjournalonline.com/schools/author-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor/15616/">
<meta property="og:title" content="Author Janet Wong Brings a Poetry Suitcase to Briarcliff Manor" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://riverjournalonline.com/wp-content/uploads/2019/06/B-1-Janet-Wong-at-Todd-720x480.jpg" />
 


<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="icon" type="image/png" href="https://riverjournalonline.com/wp-content/uploads/2019/01/favicon.png" />
<title>Author Janet Wong Brings a Poetry Suitcase to Briarcliff Manor &#8211; River Journal Online &#8211; Tarrytown News, Sleepy Hollow News, Irvington News</title>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="River Journal Online - Tarrytown News, Sleepy Hollow News, Irvington News &raquo; Feed" href="https://riverjournalonline.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="River Journal Online - Tarrytown News, Sleepy Hollow News, Irvington News &raquo; Comments Feed" href="https://riverjournalonline.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="River Journal Online - Tarrytown News, Sleepy Hollow News, Irvington News &raquo; iCal Feed" href="https://riverjournalonline.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="River Journal Online - Tarrytown News, Sleepy Hollow News, Irvington News &raquo; Author Janet Wong Brings a Poetry Suitcase to Briarcliff Manor Comments Feed" href="https://riverjournalonline.com/schools/author-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor/15616/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/riverjournalonline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='cf_css_base-css'  href='https://riverjournalonline.com/wp-content/plugins/contestfriend/css/cf_base.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://riverjournalonline.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.9.11' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://riverjournalonline.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='newsnow_pro-style-css'  href='https://riverjournalonline.com/wp-content/themes/newsnow-pro/style.css?ver=20180523' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-style-css'  href='https://riverjournalonline.com/wp-content/themes/newsnow-pro/genericons/genericons.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-style-css'  href='https://riverjournalonline.com/wp-content/themes/newsnow-pro/responsive.css?ver=20161209' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://riverjournalonline.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://riverjournalonline.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://riverjournalonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://riverjournalonline.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Scholar-Athlete Spotlight: Miranda Farman' href='https://riverjournalonline.com/schools/scholar-athlete-spotlight-miranda-farman/15714/' />
<meta name="generator" content="WordPress 5.2.1" />
<link rel="canonical" href="https://riverjournalonline.com/schools/author-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor/15616/" />
<link rel='shortlink' href='https://riverjournalonline.com/?p=15616' />
<link rel="alternate" type="application/json+oembed" href="https://riverjournalonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverjournalonline.com%2Fschools%2Fauthor-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor%2F15616%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://riverjournalonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Friverjournalonline.com%2Fschools%2Fauthor-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor%2F15616%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://riverjournalonline.com"><link rel="https://theeventscalendar.com/" href="https://riverjournalonline.com/wp-json/tribe/events/v1/" /><link rel="amphtml" href="https://riverjournalonline.com/schools/author-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor/15616/amp/">
<!-- Begin Custom CSS -->
<style type="text/css" id="demo-custom-css">
.primary{color:#0093b8;font-family:Georgia,Times,"Times New Roman",serif;}.secondary{font-family:"Helvetica Neue",Helvetica,Arial,sans-serif;}
</style>
<!-- End Custom CSS -->

<style type="text/css" media="all">
	body,
	.breadcrumbs h3,
	.section-header h3,
	label,
	input,
	input[type="text"],
	input[type="email"],
	input[type="url"],
	input[type="search"],
	input[type="password"],
	textarea,
	button,
	.btn,
	input[type="submit"],
	input[type="reset"],
	input[type="button"],
	table,
	.sidebar .widget_ad .widget-title,
	.site-footer .widget_ad .widget-title {
		font-family: "serif", "Helvetica Neue", Helvetica, Arial, sans-serif;
	}
	h1,h2,h3,h4,h5,h6 {
		font-family: "sans-serif", "Helvetica Neue", Helvetica, Arial, sans-serif;
	}
	a,
	a:visited,
	.sf-menu ul li li a:hover,
	.sf-menu li.sfHover li a:hover,
	#primary-menu li a:hover,
	#primary-menu li.current-menu-item a,
	#primary-menu li li a:hover,
	#primary-menu li li.current-menu-item a:hover,
	#secondary-menu li li a:hover,
	.entry-meta a,
	.edit-link a,
	.comment-reply-title small a:hover,
	.entry-content a,
	.entry-content a:visited,
	.page-content a,
	.page-content a:visited,
	.pagination .page-numbers.current,
	#latest-content h3,
	.content-block .section-heading h3 a,
	.content-block .section-heading h3 a:visited,
	.header-search .search-submit:hover {
		color: #0093b8;
	}	
	a:hover,
	.site-title a:hover,
	.mobile-menu ul li a:hover,
	.pagination .page-numbers:hover,	
	.sidebar .widget a:hover,
	.site-footer .widget a:hover,
	.sidebar .widget ul li a:hover,
	.site-footer .widget ul li a:hover,
	.entry-related .hentry .entry-title a:hover,
	.author-box .author-name span a:hover,
	.entry-tags .tag-links a:hover:before,
	.widget_tag_cloud .tagcloud a:hover:before,
	.entry-content a:hover,
	.page-content a:hover,
	.content-block .section-heading h3 a:hover,
	.content-block .section-heading .section-more-link a:hover,
	.entry-meta .entry-comment a:hover,
	.entry-title a:hover,
	.page-content ul li:before,
	.entry-content ul li:before {
		color: #ff0000;
	}
	.mobile-menu-icon .menu-icon-close,
	.mobile-menu-icon .menu-icon-open,
	.widget_newsletter form input[type="submit"],
	.widget_newsletter form input[type="button"],
	.widget_newsletter form button,
	.more-button a,
	.more-button a:hover,
	.entry-header .entry-category-icon a,
	#secondary-menu li.current-menu-item a,
	#secondary-menu li.sfHover a,
	#secondary-menu li a:hover {
		background-color: #0093b8;
	}
	#secondary-bar,
	button,
	.btn,
	input[type="submit"],
	input[type="reset"],
	input[type="button"],
	button:hover,
	.btn:hover,
	input[type="reset"]:hover,
	input[type="submit"]:hover,
	input[type="button"]:hover {
		background-color: #004b79;
	}
</style>
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-15616 single-format-standard wp-custom-logo tribe-no-js tribe-bar-is-disabled tribe-theme-newsnow-pro group-blog">

<div id="page" class="site">

	<header id="masthead" class="site-header clear">

		<div id="primary-bar">

			<div class="container">

			<nav id="primary-nav" class="main-navigation">

				<div class="menu-top-menu-container"><ul id="primary-menu" class="sf-menu"><li id="menu-item-12805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12805"><a href="https://riverjournalonline.com/contact-river-journal/">Contact</a></li>
<li id="menu-item-12973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12973"><a href="https://riverjournalonline.com/river-journal-staff/">Staff</a></li>
<li id="menu-item-12806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12806"><a href="https://www.facebook.com/theriverjournal/">Facebook</a></li>
<li id="menu-item-13357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13357"><a href="https://twitter.com/theriverjournal">Twitter</a></li>
</ul></div>
			</nav><!-- #primary-nav -->	

			
				<div class="header-search">
					<form id="searchform" method="get" action="https://riverjournalonline.com/">
						<input type="search" name="s" class="search-input" placeholder="Search..." autocomplete="off">
						<button type="submit" class="search-submit"><span class="genericon genericon-search"></span></button>		
					</form>
				</div><!-- .header-search -->

			
			</div><!-- .container -->

		</div><!-- #primary-bar -->	

		<div class="site-start clear">

			<div class="container">

			<div class="site-branding">

								
				<div id="logo">
					<span class="helper"></span>
					<a href="https://riverjournalonline.com/" rel="home">
						<img src="https://riverjournalonline.com/wp-content/uploads/2018/11/River-Journal-Masthead.png" alt="River Journal Logo"/>
					</a>
				</div><!-- #logo -->

				
			</div><!-- .site-branding -->

			<div id="happythemes-ad-7" class="header-ad widget_advert advert-widget"><div class="adwidget-mobile"><a href="https://phelpshospital.org?utm_source=River Journal&utm_medium=display&utm_campaign=brand&utm_campaign=brand"><img src="https://riverjournalonline.com/wp-content/uploads/2018/12/Phelps_Brand-728x90.jpg" alt="" /></a></div></div>
			<span class="mobile-menu-icon">
				<span class="menu-icon-open">Menu</span>
				<span class="menu-icon-close"><span class="genericon genericon-close"></span></span>		
			</span>	
			
			</div><!-- .container -->

		</div><!-- .site-start -->

		<div id="secondary-bar" class="container clear">

			<div class="container">

			<nav id="secondary-nav" class="secondary-navigation">

				<div class="menu-main-menu-container"><ul id="secondary-menu" class="sf-menu"><li id="menu-item-9692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9692"><a>Villages</a>
<ul class="sub-menu">
	<li id="menu-item-13360" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-13360"><a href="https://riverjournalonline.com/category/villages/briarcliff-manor/">Briarcliff Manor</a></li>
	<li id="menu-item-9695" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9695"><a href="https://riverjournalonline.com/category/villages/irvington/">Irvington</a></li>
	<li id="menu-item-9714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9714"><a href="https://riverjournalonline.com/category/villages/ossining/">Ossining</a></li>
	<li id="menu-item-9694" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9694"><a href="https://riverjournalonline.com/category/villages/sleepyhollow/">Sleepy Hollow</a></li>
	<li id="menu-item-9693" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9693"><a href="https://riverjournalonline.com/category/villages/tarrytown/">Tarrytown</a></li>
	<li id="menu-item-13378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13378"><a href="https://riverjournalonline.com/category/villages/pocantico/">Pocantico</a></li>
</ul>
</li>
<li id="menu-item-12807" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12807"><a href="https://riverjournalonline.com/category/schools/">Schools</a></li>
<li id="menu-item-9697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9697"><a>Around Town</a>
<ul class="sub-menu">
	<li id="menu-item-9702" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9702"><a href="https://riverjournalonline.com/category/around-town/around-the-house/">Around the House</a></li>
	<li id="menu-item-13260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13260"><a href="https://riverjournalonline.com/category/around-town/for-the-local-good/">For the Local Good</a></li>
	<li id="menu-item-13660" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13660"><a href="https://riverjournalonline.com/category/around-town/sports/">Sports</a></li>
	<li id="menu-item-9701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9701"><a href="https://riverjournalonline.com/category/around-town/dining-out-around-town/">Dining Out</a></li>
	<li id="menu-item-15746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15746"><a href="https://riverjournalonline.com/category/around-town/pet-of-the-month/">Pet of the Month</a></li>
	<li id="menu-item-13664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13664"><a href="https://riverjournalonline.com/category/around-town/arts-culture/">Arts &#038; Culture</a></li>
	<li id="menu-item-13392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13392"><a href="https://riverjournalonline.com/category/around-town/sponsored-content/">Sponsored Content</a></li>
	<li id="menu-item-13688" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13688"><a href="https://riverjournalonline.com/category/around-town/promotions/">Promotions</a></li>
	<li id="menu-item-9703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9703"><a href="https://riverjournalonline.com/category/around-town/health/">Health</a></li>
	<li id="menu-item-13764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13764"><a href="https://riverjournalonline.com/category/around-town/real-estate/">Real Estate</a></li>
	<li id="menu-item-13450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13450"><a href="https://riverjournalonline.com/category/around-town/slice-of-history/">Slice of History</a></li>
	<li id="menu-item-13449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13449"><a href="https://riverjournalonline.com/category/around-town/obituaries/">Obituaries</a></li>
	<li id="menu-item-9700" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9700"><a href="https://riverjournalonline.com/category/around-town/past-times/">Past Times</a></li>
</ul>
</li>
<li id="menu-item-9699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9699"><a href="https://riverjournalonline.com/category/business/">Business</a></li>
<li id="menu-item-9710" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9710"><a>Blogs</a>
<ul class="sub-menu">
	<li id="menu-item-14382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14382"><a href="https://riverjournalonline.com/category/blogs/city-girl/">City Girl</a></li>
	<li id="menu-item-14136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14136"><a href="https://riverjournalonline.com/category/blogs/trail-tunnel-notes/">Trail &#038; Tunnel Notes</a></li>
	<li id="menu-item-14905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14905"><a href="https://riverjournalonline.com/category/blogs/road-to-college/">Road to College</a></li>
	<li id="menu-item-9706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9706"><a href="https://riverjournalonline.com/category/blogs/river-dad/">River Dad</a></li>
	<li id="menu-item-9712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9712"><a href="https://riverjournalonline.com/category/blogs/about-aging/">About Aging</a></li>
	<li id="menu-item-9713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9713"><a href="https://riverjournalonline.com/category/blogs/fabulously-fit/">Fabulously Fit</a></li>
	<li id="menu-item-9709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9709"><a href="https://riverjournalonline.com/category/blogs/the-cancer-made-me-do-it/">The Cancer Made Me Do It</a></li>
</ul>
</li>
<li id="menu-item-12808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12808"><a href="https://riverjournalonline.com/category/letters/">Letters</a></li>
<li id="menu-item-13084" class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-has-children menu-item-13084"><a href="https://riverjournalonline.com/events/">Events</a>
<ul class="sub-menu">
	<li id="menu-item-13118" class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-13118"><a href="https://riverjournalonline.com/events/">Calendar</a></li>
	<li id="menu-item-13114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13114"><a href="/events/community/add">Add Event</a></li>
</ul>
</li>
</ul></div>
			</nav><!-- #secondary-nav -->

			</div><!-- .container -->				

		</div><!-- .secondary-bar -->

		<div class="mobile-menu clear">

			<div class="container">

			<div class="menu-left"><h3>Pages</h3><div class="menu-top-menu-container"><ul id="primary-mobile-menu" class=""><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12805"><a href="https://riverjournalonline.com/contact-river-journal/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12973"><a href="https://riverjournalonline.com/river-journal-staff/">Staff</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12806"><a href="https://www.facebook.com/theriverjournal/">Facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13357"><a href="https://twitter.com/theriverjournal">Twitter</a></li>
</ul></div></div><div class="menu-right"><h3>Categories</h3><div class="menu-main-menu-container"><ul id="secondary-mobile-menu" class=""><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9692"><a>Villages</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12807"><a href="https://riverjournalonline.com/category/schools/">Schools</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9697"><a>Around Town</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9699"><a href="https://riverjournalonline.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9710"><a>Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12808"><a href="https://riverjournalonline.com/category/letters/">Letters</a></li>
<li class="menu-item menu-item-type-post_type_archive menu-item-object-tribe_events menu-item-has-children menu-item-13084"><a href="https://riverjournalonline.com/events/">Events</a></li>
</ul></div></div>
			</div><!-- .container -->

		</div><!-- .mobile-menu -->	

					
			<span class="search-icon">
				<span class="genericon genericon-search"></span>
				<span class="genericon genericon-close"></span>			
			</span>

								

	</header><!-- #masthead -->

	<div id="content" class="site-content container clear">

	<div id="primary" class="content-area">

		<main id="main" class="site-main" >

		<div id="happythemes-ad-7" class="header-ad widget_advert advert-widget"><div class="adwidget-mobile"><a href="https://phelpshospital.org?utm_source=River Journal&utm_medium=display&utm_campaign=brand&utm_campaign=brand"><img src="https://riverjournalonline.com/wp-content/uploads/2018/12/Phelps_Brand-728x90.jpg" alt="" /></a></div></div>		
<article id="post-15616" class="post-15616 post type-post status-publish format-standard has-post-thumbnail hentry category-briarcliff-manor category-schools category-villages">
	<header class="entry-header clear">
	
		<div class="entry-category-icon"><a href="https://riverjournalonline.com/category/villages/briarcliff-manor/" title="View all posts in Briarcliff Manor" >Briarcliff Manor</a> </div>

		<h1 class="entry-title">Author Janet Wong Brings a Poetry Suitcase to Briarcliff Manor</h1>
		<div class="entry-meta clear">

	<span class="entry-author"><a href="https://riverjournalonline.com/author/evelyn-mertens/"></a> <a href="https://riverjournalonline.com/author/evelyn-mertens/" title="Posts by Evelyn Mertens" rel="author">Evelyn Mertens</a> &#8212; </span> 
	<span class="entry-date">June 9, 2019</span>

</div><!-- .entry-meta -->
		
		<div class="social-share-icons">

	<a href="https://twitter.com/intent/tweet?text=Author+Janet+Wong+Brings+a+Poetry+Suitcase+to+Briarcliff+Manor&amp;url=https%3A%2F%2Friverjournalonline.com%2Fschools%2Fauthor-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor%2F15616%2F" target="_blank"><img src="https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/img/icon-twitter-square.png" alt=""/></a>

	<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Friverjournalonline.com%2Fschools%2Fauthor-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor%2F15616%2F" target="_blank"><img src="https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/img/icon-facebook-square.png" alt=""/></a>

	<a href="mailto:?subject=Author%20Janet%20Wong%20Brings%20a%20Poetry%20Suitcase%20to%20Briarcliff%20Manor&body=https://riverjournalonline.com/schools/author-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor/15616/" target="_blank"><img src="https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/img/icon-mail-square.png" alt=""/></a>

</div>
	</header><!-- .entry-header -->

	<div class="entry-content">
		<figure id="attachment_15617" aria-describedby="caption-attachment-15617" style="width: 300px" class="wp-caption alignleft"><img class="size-medium wp-image-15617" src="https://riverjournalonline.com/wp-content/uploads/2019/06/B-1-Janet-Wong-at-Todd-300x225.jpg" alt="" width="300" height="225" /><figcaption id="caption-attachment-15617" class="wp-caption-text">Janet Wong at Todd</figcaption></figure>
<p>Janet Wong, author of over 30 children’s books and volumes of poetry, visited Todd School in Briarcliff Manor this spring to talk to students about her love of language and the importance of poetry. Recalling that as a child she missed a chance to learn another language out of fear that others would make fun of her, she encouraged the students to “be brave and embrace being unique!”</p>
<p>She shared several of her poems, then opened her “poetry suitcase” containing an assortment of props including a turtle, a snake, a hat, noodles and other treasures. “A suitcase takes you places—and so does poetry,” said Wong.</p>
<p>She read a poem about her father and advised all: “If you write something that’s about someone, don’t identify them! …Rip it up into little pieces and throw it in three different garbage cans.” The students burst into laughter.</p>
<p>Janet’s journey began 25 years ago when she began to question her career as a lawyer at Universal Studios Hollywood. She’d also worked as a substitute teacher while studying at Yale Law School, yet she knew that teaching wasn’t her path. One day, while searching in a bookstore for gifts, the idea hit her: “Someone wrote these books. Why not ME?” The rest is history.</p>
<p>Todd Librarian Tara Phethean, coordinator of the library’s special events, said, “Author visits are always an exciting time at Todd and each one is a unique opportunity to engage the students.”</p>
<p>To learn more about Janet, visit janetwong.com.</p>
	</div><!-- .entry-content -->

	<span class="entry-tags">

					
	</span><!-- .entry-tags -->

</article><!-- #post-## -->



<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/schools/author-janet-wong-brings-a-poetry-suitcase-to-briarcliff-manor/15616/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://riverjournalonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='15616' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->

		<div class="entry-related clear">
			<h3>Recommended For You</h3>
			<div class="related-loop clear">
														<div class="hentry">
													<a class="thumbnail-link" href="https://riverjournalonline.com/schools/scholar-athlete-spotlight-miranda-farman/15714/">
								<div class="thumbnail-wrap">
									<img width="300" height="200" src="https://riverjournalonline.com/wp-content/uploads/2019/06/Miranda-Farman-Soccer-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="" srcset="https://riverjournalonline.com/wp-content/uploads/2019/06/Miranda-Farman-Soccer-300x200.jpg 300w, https://riverjournalonline.com/wp-content/uploads/2019/06/Miranda-Farman-Soccer-600x399.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" />								</div><!-- .thumbnail-wrap -->
							</a>
										
						<h2 class="entry-title"><a href="https://riverjournalonline.com/schools/scholar-athlete-spotlight-miranda-farman/15714/">Scholar-Athlete Spotlight: Miranda Farman</a></h2>
					</div><!-- .grid -->
														<div class="hentry">
													<a class="thumbnail-link" href="https://riverjournalonline.com/schools/irvington-art-show-showcases-student-talent/15634/">
								<div class="thumbnail-wrap">
									<img width="300" height="200" src="https://riverjournalonline.com/wp-content/uploads/2019/06/I-3-Irvington-Art-Show-2-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="" srcset="https://riverjournalonline.com/wp-content/uploads/2019/06/I-3-Irvington-Art-Show-2-300x200.jpg 300w, https://riverjournalonline.com/wp-content/uploads/2019/06/I-3-Irvington-Art-Show-2-720x480.jpg 720w, https://riverjournalonline.com/wp-content/uploads/2019/06/I-3-Irvington-Art-Show-2-600x400.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" />								</div><!-- .thumbnail-wrap -->
							</a>
										
						<h2 class="entry-title"><a href="https://riverjournalonline.com/schools/irvington-art-show-showcases-student-talent/15634/">Irvington Art Show Showcases Student Talent</a></h2>
					</div><!-- .grid -->
														<div class="hentry">
													<a class="thumbnail-link" href="https://riverjournalonline.com/schools/sleepy-hollow-high-school-teacher-presents-and-implements-new-science-curriculum/15657/">
								<div class="thumbnail-wrap">
									<img width="300" height="200" src="https://riverjournalonline.com/wp-content/uploads/2019/06/T-6-Sleepy-Hollow-High-School-Science-Teacher-Leana-Peltier-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="" srcset="https://riverjournalonline.com/wp-content/uploads/2019/06/T-6-Sleepy-Hollow-High-School-Science-Teacher-Leana-Peltier-300x200.jpg 300w, https://riverjournalonline.com/wp-content/uploads/2019/06/T-6-Sleepy-Hollow-High-School-Science-Teacher-Leana-Peltier-720x480.jpg 720w, https://riverjournalonline.com/wp-content/uploads/2019/06/T-6-Sleepy-Hollow-High-School-Science-Teacher-Leana-Peltier-600x400.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" />								</div><!-- .thumbnail-wrap -->
							</a>
										
						<h2 class="entry-title"><a href="https://riverjournalonline.com/schools/sleepy-hollow-high-school-teacher-presents-and-implements-new-science-curriculum/15657/">Sleepy Hollow High School Teacher Presents and Implements New Science Curriculum</a></h2>
					</div><!-- .grid -->
														<div class="hentry last">
													<a class="thumbnail-link" href="https://riverjournalonline.com/around-town/health/stress-reduction-and-pain-relief-holistically/15731/">
								<div class="thumbnail-wrap">
									<img width="300" height="200" src="https://riverjournalonline.com/wp-content/uploads/2019/06/Cathleen-Bonvento-2-e1560085289353-300x200.jpg" class="attachment-post_thumb size-post_thumb wp-post-image" alt="" srcset="https://riverjournalonline.com/wp-content/uploads/2019/06/Cathleen-Bonvento-2-e1560085289353-300x200.jpg 300w, https://riverjournalonline.com/wp-content/uploads/2019/06/Cathleen-Bonvento-2-e1560085289353-720x480.jpg 720w, https://riverjournalonline.com/wp-content/uploads/2019/06/Cathleen-Bonvento-2-e1560085289353-600x400.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" />								</div><!-- .thumbnail-wrap -->
							</a>
										
						<h2 class="entry-title"><a href="https://riverjournalonline.com/around-town/health/stress-reduction-and-pain-relief-holistically/15731/">Sponsored Content: Stress Reduction and Pain Relief . . . Holistically</a></h2>
					</div><!-- .grid -->
							</div><!-- .related-posts -->
		</div><!-- .entry-related -->

	

		</main><!-- #main -->
	</div><!-- #primary -->


<aside id="secondary" class="widget-area sidebar">


	<div id="happythemes-ad-8" class="widget widget_advert advert-widget"><div class="adwidget"><a href="https://www.geico.com/insurance-agents/new-york/westchester"><img src="https://riverjournalonline.com/wp-content/uploads/2019/01/Geioc_300x250__Photo_Ad_01032019.jpg" alt="" /></a></div></div><div id="happythemes-ad-6" class="widget widget_advert advert-widget"><div class="adwidget"><a href="http://www.hudsonharborny.com/lighthouse"><img src="https://riverjournalonline.com/wp-content/uploads/2018/11/hh-lighthouse-banner-ad-for-rjo-2.jpg" alt="" /></a></div></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="https://www.facebook.com/plugins/likebox.php?href=http://www.facebook.com/pages/River-Journal/380811704904&amp;width=300&amp;height=225" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px;height:225px;" allowtransparency="true"></iframe></div></div><div id="tribe-events-list-widget-2" class="widget tribe-events-list-widget"><h2 class="widget-title"><span>Upcoming Local Events</span></h2>
	<ol class="tribe-list-widget">
					<li class="tribe-events-list-widget-events type-tribe_events post-14671 tribe-clearfix tribe-events-category-art">
				
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="https://riverjournalonline.com/event/exhibit-colorproblems-paintings-by-susan-rowe-harrison/" rel="bookmark">Exhibit: #colorproblems, paintings by Susan Rowe Harrison</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 19 @ 10:00 am</span> - <span class="tribe-event-date-end">June 23 @ 4:00 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-15479 tribe-clearfix">
				
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="https://riverjournalonline.com/event/healthy-life-series-continues-in-june-at-phelps-hospital-3/" rel="bookmark">Healthy Life Series Continues in June at Phelps Hospital</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">June 1 @ 12:00 am</span> - <span class="tribe-event-date-end">July 31 @ 12:00 am</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-15392 tribe-clearfix tribe-events-category-art tribe-events-category-culture tribe-events-category-night-out tribe-events-venue-15393 tribe-events-organizer-14179">
				
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="https://riverjournalonline.com/event/mary-ellis-so-far-pop-art-to-abstract-expressionism/" rel="bookmark">Mary Ellis-So Far : Pop Art to Abstract Expressionism</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">June 8 @ 6:00 pm</span> - <span class="tribe-event-date-end">June 30 @ 4:00 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-15465 tribe-clearfix tribe-events-category-art tribe-events-category-culture tribe-events-category-night-out tribe-events-venue-15393 tribe-events-organizer-14179 tribe-events-organizer-15466">
				
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="https://riverjournalonline.com/event/mary-ellis-so-far-pop-art-to-abstract-expressionism-2/" rel="bookmark">Mary Ellis-So Far : Pop Art to Abstract Expressionism</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">June 8 @ 6:00 pm</span> - <span class="tribe-event-date-end">June 30 @ 6:00 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-15718 tribe-clearfix tribe-events-venue-13179 tribe-events-organizer-15719">
				
								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="https://riverjournalonline.com/event/garden-tours-of-untermyer-gardens/" rel="bookmark">Garden tours of Untermyer Gardens</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">June 9 @ 8:00 am</span> - <span class="tribe-event-time">5:00 pm</span>				</div>

							</li>
			</ol><!-- .tribe-list-widget -->

	<p class="tribe-events-widget-link">
		<a href="https://riverjournalonline.com/events/" rel="bookmark">View All Events</a>
	</p>

</div>

</aside><!-- #secondary -->


	</div><!-- #content .site-content -->
	
	<footer id="colophon" class="site-footer">

		
			<div class="footer-columns clear">

				<div class="container">

					<div class="footer-column footer-column-1" style="width:70%;">
						<div id="custom_html-7" class="widget_text widget footer-widget widget_custom_html"><div class="textwidget custom-html-widget">RiverJournalOnline is the online publication of River Towns Media LLC and River Journal, Briarcliff Manor, NY.  No part of River Journal including photos, artwork, ads and text may be reproduced without the written consent of the Publisher.</div></div>					</div>

					<div class="footer-column footer-column-2">
											</div>

				</div><!-- .container -->

			</div><!-- .footer-columns -->

		
		<div class="clear"></div>

		<div id="site-bottom" class="clear">

			<div class="container">

			<div class="site-info">

				© Copyright 2018, All Rights Reserved | <a href="https://riverjournalonline.com/privacy-policy/" title="Privacy Policy">Privacy Policy</a> | <a href="https://riverjournalonline.com/terms-of-use/" title="Terms of Use">Terms of Use</a>
			</div><!-- .site-info -->

			<div class="menu-footer-container"><ul id="footer-menu" class="footer-nav"><li id="menu-item-12974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12974"><a href="https://riverjournalonline.com/river-journal-staff/">River Journal Staff</a></li>
<li id="menu-item-12975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12975"><a href="https://riverjournalonline.com/contact-river-journal/">Contact River Journal</a></li>
<li id="menu-item-12976" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12976"><a href="https://www.facebook.com/theriverjournal/">Facebook</a></li>
</ul></div>	

			</div><!-- .container -->

		</div><!-- #site-bottom -->
							
	</footer><!-- #colophon -->

</div><!-- #page -->



<script type="text/javascript">

(function($){ //create closure so we can safely use $ as alias for jQuery

    $(document).ready(function(){

        "use strict"; 

        $("#secondary-bar").sticky( { topSpacing: 0 } );
    });

})(jQuery);

</script>


		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"fcf1a8fc29","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script><link rel='stylesheet' id='tribe-events-custom-jquery-styles-css'  href='https://riverjournalonline.com/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=4.9.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-bootstrap-datepicker-css-css'  href='https://riverjournalonline.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=4.9.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css'  href='https://riverjournalonline.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css?ver=4.9.3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/js/superfish.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/js/modernizr.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/js/html5.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/js/jquery.sticky.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/js/jquery.bxslider.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-content/themes/newsnow-pro/assets/js/jquery.custom.js?ver=20170628'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-includes/js/comment-reply.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://riverjournalonline.com/wp-includes/js/wp-embed.min.js?ver=5.2.1'></script>

<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-12544501-1");
pageTracker._trackPageview();
} catch(err) {}</script>



<script>
jQuery(document).ready(function($) {
	$('a')
		.filter('[href^="http"], [href^="//"]')
		.not('[href*="' + window.location.host + '"]')
		.attr('rel', 'noopener noreferrer')
		.attr('target', '_blank');
});
</script>


</body>
</html>
